Server Help Forum Index Server Help
Community forums for Subgame, ASSS, and bots
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   StatisticsStatistics   RegisterRegister 
 ProfileProfile   Login to check your private messagesLogin to check your private messages   LoginLogin (SSL) 

Server Help | ASSS Wiki (0) | Shanky.com
Continuum and Wine on OpenSUSE 11.2 x86_64

 
Post new topic   Reply to topic Printable version
 View previous topic  Know of any quality material on ANNs? Post :: Post Crc32  View next topic  
Author Message
Arnk Kilo Dylie
Seasoned Helper


Age:30
Gender:Gender:Male
Joined: Jul 14 2006
Posts: 108
Offline

PostPosted: Fri Feb 12, 2010 1:20 am    Post subject: Continuum and Wine on OpenSUSE 11.2 x86_64 Reply to topic Reply with quote

Continuum ran great using the usual kernel32.dll.so swapout on this same computer running OpenSUSE 11.1 using NVIDIA drivers. Today I installed 11.2 from scratch. Much to my dismay, the substitute kernel32.dll.so was too old for the wine version (or something, but basically it immediately segfaulted like other times I tried upgrading wine) so I had to do some digging for an old version.

Using old versions (1.0.1 and 1.1.9), I was able to put in the kernel32.dll.so and run Continuum. No immediate segfault, but once the zone list popped up there was a segfault fairly soon after that, coming from menu40.dll. Figuring it was some weird incompatibility I tried building from source of the newest (applying the proper patch to process.c) and the behavior was exactly the same. For kicks I tried building from source of several versions, and ultimately the same problem happens.

So after wasting my entire day working on this, I'm trying to figure out how it is Continuum is crashing. I doubt it's Wine's fault directly because at least one of the older versions should work. I made sure my Cont files weren't corrupt or anything like that, and still no dice. I'd be willing to put some money that this is Continuum shenanigans, and if so, fixing it might be really tough.

Here is some of the output from when it crashes.
Code: Show/Hide

akd@linux-erqa:~/.wine/drive_c/Program Files/Continuum> wine Continuum.exe
fixme:system:SetProcessDPIAware stub!
fixme:dwmapi:DwmIsCompositionEnabled 0x33cf34
fixme:iphlpapi:NotifyAddrChange (Handle 0xa6ce8d8, overlapped 0xa6ce8e0): stub
fixme:iphlpapi:GetAdaptersAddresses no support for IPv6 addresses
wine: configuration in '/home/akd/.wine' has been updated.
fixme:win:EnumDisplayDevicesW ((null),0,0x32f140,0x00000000), stub!
wine: Unhandled page fault on read access to 0x00000000 at address 0xbe8432 (thread 0009), starting debugger...
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x00be8432).


Threads:
process  tid      prio (all id:s are in hex)
00000008 (D) C:\Program Files\Continuum\Continuum.exe
   0000001d    0
   0000001c    0
   00000019    0
   00000009    0 <==
0000000e services.exe
   00000016    0
   00000015    0
   00000014    0
   00000010    0
   0000000f    0
00000011 winedevice.exe
   00000018    0
   00000017    0
   00000013    0
   00000012    0
0000001a explorer.exe
   0000001b    0


=>0 0x00be8432 in menu040 (+0x18432) (0x0032f554)
  1 0x7ee227ac call_window_proc+0x5c(hwnd=<register EDI not in topmost frame>, msg=32771, wp=57006, lp=0, result=<register ESI not in topmost frame>, arg=0xbe5c30) [/home/akd/code/wine-1.1.38/dlls/user32/winproc.c:242] in user32 (0x0032f5a4)
  2 0x7ee23b0f WINPROC_call_window+0x10f(hwnd=<register EDI not in topmost frame>, msg=32771, wParam=57006, lParam=0, result=0x32f6d8, unicode=0, mapping=WMCHAR_MAP_DISPATCHMESSAGE) [/home/akd/code/wine-1.1.38/dlls/user32/winproc.c:912] in user32 (0x0032f5f4)
  3 0x7ede7cbb DispatchMessageA+0x9b(msg=0x32f704) [/home/akd/code/wine-1.1.38/dlls/user32/message.c:3072] in user32 (0x0032f6e4)
  4 0x00be13a8 in menu040 (+0x113a8) (0x7ede7c20)
err:seh:setup_exception_record nested exception on signal stack in thread 0026 eip 7b9675be esp 7ffd3920 stack 0xd42000-0xe40000
Segmentation fault


Hopefully I'm not the only one who's encountered this problem. Any thoughts?
Back to top
View users profile Send private message Add User to Ignore List Visit posters website
docflabby-lazy
Guest


Offline

PostPosted: Fri Feb 12, 2010 10:24 am    Post subject: Reply to topic Reply with quote

My advice would be compile wine from source.

I havnt had a chance to recompile the .so file to a newish version of wine yet...

http://www.ssforum.net/index.php?showtopic=23975
Back to top
Arnk Kilo Dylie
Seasoned Helper


Age:30
Gender:Gender:Male
Joined: Jul 14 2006
Posts: 108
Offline

PostPosted: Fri Feb 12, 2010 1:09 pm    Post subject: Re: Continuum and Wine on OpenSUSE 11.2 x86_64 Reply to topic Reply with quote

Arnk Kilo Dylie wrote:
Figuring it was some weird incompatibility I tried building from source of the newest (applying the proper patch to process.c) and the behavior was exactly the same. For kicks I tried building from source of several versions, and ultimately the same problem happens.

:?


P.S. that sed patch is no good for newer versions, as would be expected. it replaces the wrong line. it sure caught me off guard, it'd be better to just tell people where to look.
Back to top
View users profile Send private message Add User to Ignore List Visit posters website
Arnk Kilo Dylie
Seasoned Helper


Age:30
Gender:Gender:Male
Joined: Jul 14 2006
Posts: 108
Offline

PostPosted: Mon Feb 15, 2010 1:21 pm    Post subject: Reply to topic Reply with quote

Just an update, I am not sure why, but Continuum .39pr1 runs just fine (though obviously I cannot use it to connect to most zones.) Something is really weird about menu40.dll.. and I'm pretty sure I can't use .39's menu dll instead (though I'll try.)
Back to top
View users profile Send private message Add User to Ignore List Visit posters website
Arnk Kilo Dylie
Seasoned Helper


Age:30
Gender:Gender:Male
Joined: Jul 14 2006
Posts: 108
Offline

PostPosted: Mon Jul 12, 2010 12:24 am    Post subject: Reply to topic Reply with quote

All right, menu040.dll still seems to be dying hard even in OpenSUSE 11.3 with the newest wine version. I've built wine from scratch countless times in different versions over these months to apply the process.c patch, no change in behavior.

It seems even menu040.dll is protected from being patched or substituted, so my options aren't looking real good here.

So, any ideas on what to try next? About all I've learned is that on my 32-bit 9 year old box, Continuum .40 will run fine in openSUSE 11.3, so the problem is either with running on x86_64 (ugh) or my computer (UGH.) Would rather not abandon x86_64, but it'll be worth a shot anyway.
Back to top
View users profile Send private message Add User to Ignore List Visit posters website
Display posts from previous:   
Post new topic   Reply to topic    Server Help Forum Index -> Non-Subspace Related Coding All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum
View online users | View Statistics | View Ignored List


Software by php BB © php BB Group
Server Load: 44 page(s) served in previous 5 minutes.

phpBB Created this page in 0.070475 seconds : 30 queries executed (46.2%): GZIP compression disabled