Server Help Forum Index Server Help
Community forums for Subgame, ASSS, and bots
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   StatisticsStatistics   RegisterRegister 
 ProfileProfile   Login to check your private messagesLogin to check your private messages   LoginLogin (SSL) 

Server Help | ASSS Wiki (0) | Shanky.com
my zone server and bot troubles

 
Post new topic   Reply to topic Printable version
 View previous topic  merve bot.37 Post :: Post My Last Reply  View next topic  
Author Message
Souldew
Novice


Age:28
Gender:Gender:Female
Joined: Jul 20 2008
Posts: 48
Location: san antonio texas
Offline

PostPosted: Sun Jul 20, 2008 10:24 am    Post subject: my zone server and bot troubles Reply to topic Reply with quote

on my zone it ship-bot says resigster on billing server
and my server keeps saying re-read settings: 0ms wtf do i doooooooooooooooooooooooooooo im trying to get it going but nothing is going right
Back to top
View users profile Send private message Add User to Ignore List Send email
Samapico
No, these DO NOT look like penises, ok?


Age:31
Gender:Gender:Male
Joined: May 08 2003
Posts: 1252
Location: Montreal, Canada
Offline

PostPosted: Sun Jul 20, 2008 10:32 am    Post subject: Reply to topic Reply with quote

re-read settings: 0ms is normal... it means it reloaded the server.cfg to check for any changes. Unless it says it like every second, then there's a problem.

But... that has nothing to do with bots. That would be subgame, right?
I don't understand where the bot problem is.

Oh wait... the bot you loaded probably does something to the settings; whenever a setting is changed, the server will reload them, resulting in "re-read settings". What plugin(s) are you using on the bot?
_________________
DCME co-developer
17th Parallel Head Sysop
Subspace: The Future
Back to top
View users profile Send private message Add User to Ignore List
L.C.
Server Help Squatter


Age:27
Gender:Gender:Male
Joined: Jan 03 2003
Posts: 572
Location: Missouri, US
Offline

PostPosted: Sun Jul 20, 2008 12:18 pm    Post subject: Reply to topic Reply with quote

Quote:
on my zone it ship-bot says resigster on billing server
and my server keeps saying re-read settings: 0ms wtf do i doooooooooooooooooooooooooooo im trying to get it going but nothing is going right


Translation:
Quote:
When my AI/bot connects to my zone, on Subbill/SSBilling2 it will say that the bot is being registered onto the network. In Subgame is prints out "re-reading settings: 0ms" without reason. What do I do?! I am also trying to get the bot working but nothing is happening as I want.


First of all, you want make sure that in Operators.txt you have a line 12:<your username>:. Replace <your username> with the username or playername you will be using to connect to your zone.

Now when you start your bot, it should join your zone correctly and stay put. It would start out in Spectator mode.

If your Bot is supposed to be able to play with human players, trying to fight and kill them, as well as being able to just fly around the map by itself -- you have an AI Bot.

If not, you would simply refer to it as Bot or by the name of the core -- like MERVBot.

Now if your Bot is an AI Bot, you want to private message !login to your bot once you and the Bot are safely tucked inside the zone. Then you need to type !start to the bot privately once again. The bot will spawn into the arena as the ship you configured it to be in, but you might have to spawn yourself in a ship to kill the bot to make it start working correctly; the bot might appear as ship 1 or something in a fixed position in the center of the arena just rotating or not doing anything (otherwise it will appear like the bot is maneuvering the ship around the arena looking for someone to fight and kill).

If you are using MERVBot (or a Bot), you shouldn't have anything more to do. Your bot is ready for on-demand usage.

When Subgame prints that it is rereading your zone settings, it simply means that Subgame is reloading your server.cfg, or applies any changes that have been made to it lately. Server.cfg is the file that holds information such as how fast ships go, how much items cost, how many powerballs and flags are to spawn, etc. It's generally a good thing if Subgame rereads your settings. icon_wink.gif I think Subgame also rereads your server.ini too.
Back to top
View users profile Send private message Add User to Ignore List Send email Visit posters website AIM Address Yahoo Messenger MSN Messenger
Souldew
Novice


Age:28
Gender:Gender:Female
Joined: Jul 20 2008
Posts: 48
Location: san antonio texas
Offline

PostPosted: Mon Aug 04, 2008 10:16 pm    Post subject: :>) Reply to topic Reply with quote

Thank you so much
Back to top
View users profile Send private message Add User to Ignore List Send email
Display posts from previous:   
Post new topic   Reply to topic    Server Help Forum Index -> Bot Questions All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum
View online users | View Statistics | View Ignored List


Software by php BB © php BB Group
Server Load: 167 page(s) served in previous 5 minutes.

phpBB Created this page in 0.068700 seconds : 29 queries executed (63.0%): GZIP compression disabled